ggplot2 would not install via RStudio

ggplot2 would not install via RStudio, and the detailed errors ran:

plyr not available for R3.0.2

reshape2 not available for R3.0.2

Now R3.0.2 is the default for Ubuntu14.04. so a quick google turned up the following SO discussions:

One thing that happened for me is that the version of R provided by my linux distribution (R version 3.0.2 provided by Ubuntu 14.04) was too old for the latest version of the package available on CRAN (in my case, plyr version 1.8.3 as of today). The solution was to use the packaging system of my distribution instead of trying to install from R (apt-get install r-cran-plyr  got me version 1.8.1 of plyr).

http://stackoverflow.com/questions/25721884/how-should-i-deal-with-package-xxx-is-not-available-for-r-version-x-y-z-wa

and apt-get install r-cran-plyr    worked as did the equivalent for reshape2;

Subsequently was able to install ggplot2 and then the shiny app that I wanted to run. Good.

NOTE   TODO   go over the ggplot2 tutorials

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s